• Help Support Hardline Crawlers :

Foamy Power Steering Fluid

mdo817

Well-Known Member
Joined
Jan 17, 2011
Messages
1,905
What will cause fluid to aerate to the point of being foamy. Set up is either 7.3 or 9.7 ci Eaton orbital, 8x2 double ended surplus ram, PSC reservoir mounted above a PSC performance jeep pump, with a grill mounted tranny cooler, line comes out of the top of cooler back to reservoir. System has worked good for several years, but I wound up getting a kink in the line going from reservoir to pump, straightened that out, did a 3 day run at wind rock end of last year and pump started whining pretty bad towards the end of each day, found fluids aerated. Jeep has only been ran a couple times since, and that was New Years, same thing, started off quiet, longer it ran, worst it whined, Jeep been setting since, only cranked about once a week, and moved a few times, today starting to prep for April Harlan ride, pump is quiet, but fluid is very foamy. Any ideas why? Should I just flush fluids and start over?


Sent from my iPad using Tapatalk
 

John Galbreath Jr.

38 Special & Solo Buggy
Joined
May 24, 2007
Messages
8,613
Air!!!!! Let it sit overnight. Raise axle off ground. WITHOUT engine running, turn lock to lock 25 times. Continue to check fluid, as it should be going down as air is purged. Only once you can see NO air bubbles in the reservoir should you crank it. Then for a couple of seconds no turning, check fluid.
 

John Galbreath Jr.

38 Special & Solo Buggy
Joined
May 24, 2007
Messages
8,613
From PSC website

1. The vehicle’s battery should always be disconnected before any modications are made.
2. Make sure all of the ttings in the power steering system are tight.
3. Raise all steering tires o of the ground.
4. Fill reservoir with power steering fluid (NEVER use automatic transmission uid). Leave the cap off of the reservoir.
5. Cycle the steering from lock to lock three or four times.
6. Check uid level in reservoir. Fill as needed.
7. Repeat steps 5 and 6 until a consistent level in the reservoir is reached.
8. Reconnect the battery. Replace the cap on the reservoir.
9. Start the vehicle and let it run without any steering input for 30 seconds.
10. Turn off engine.
11. Check and fill reservoir as needed, replacing cap when done.
12. Start engine and cycle steering from lock to lock 10-15 times.
13. Turn off the engine and let it stand for 10 minutes to allow air bubbles to work out of the system.
14. Repeat steps 11-14 until there are no air bubbles visible in the reservoir.
15. With the engine running, observe the fluid level in the reservoir. While looking in the reservoir,
turn off the engine. The fluid level should not change.
16. If the level does not change, check the system for leaks. If there are no leaks, test drive the
vehicle. If the level does change start over at step 4.
 

mdo817

Well-Known Member
Joined
Jan 17, 2011
Messages
1,905
Tx John, but this all started after I had done a complete bleed, and had zero bubbles, and wheeled for about 6 months. Today the foam was in reservoir after sitting for over a week, without cranking or any steering input. Just trying to figure out why or what would cause it to get to the point it is now, and the bubbles will not go away.


Sent from my iPad using Tapatalk
 

mdo817

Well-Known Member
Joined
Jan 17, 2011
Messages
1,905
Changed it after it pinched to ensure that it would not bend and pinch again


Sent from my iPad using Tapatalk
 

zjtrey

Well-Known Member
Joined
Jan 4, 2011
Messages
648
Location
North Carolina
sounds silly but make sure all your hose clamps and fittings are tight… sounds like you've had the system in place for a while, hoses can become harder over time and not bite on the hose barbs as well.. I'm with TBItoy though you're getting air in the system somewhere
 

mdo817

Well-Known Member
Joined
Jan 17, 2011
Messages
1,905
I will check them all again, but would air bubbles not go away, much like when you originally set up a system and bleed it, this one has set for over a week and there is foamy air in it. I will check all connections, flush fluids and re-bleed and see what gives.
 

1TONTJ

Amateur Hardcore
Joined
Feb 1, 2008
Messages
425
Location
North Louisiana
I fought this problem on my last rig for a long time until I finally found a tiny pin hole in the pump can where the fitting was welded on. PSC took care of it and sent me another can, problem solved. So, yeah, it could be a small leak somewhere.
 

mdo817

Well-Known Member
Joined
Jan 17, 2011
Messages
1,905
Re: Re: Re: Foamy Power Steering Fluid

1TONTJ said:
I fought this problem on my last rig for a long time until I finally found a tiny pin hole in the pump can where the fitting was welded on. PSC took care of it and sent me another can, problem solved. So, yeah, it could be a small leak somewhere.
did any fluid ever leak out or did it just such air in

Sent from my SCH-I545 using Tapatalk 2
 

Skidkid

Well-Known Member
Joined
Feb 11, 2011
Messages
184
I also recommend removing the hydraulic steering cylinder link or links off of shaft. This allows the cylinder the bottom out removing any possible trapped air. Also, make sure the layout of your steering cooler doesn't trap air. Round tube type coolers should be vertically mounted.

I've heard mounting orbital valves up high can cause trapped air as well. Your res should be the highest mounted part of your steering system.

Return line on the res must be towards the bottom edge as you need your returning fluid to be below res fluid level.
 

1TONTJ

Amateur Hardcore
Joined
Feb 1, 2008
Messages
425
Location
North Louisiana
Re: Re: Re: Foamy Power Steering Fluid

mdo817 said:
did any fluid ever leak out or did it just such air in

Sent from my SCH-I545 using Tapatalk 2

It leaked a little when the engine wasn't running but it was such a small amount it took forever to see the fluid buildup. I had to get everything squeaky clean and then use a dang magnifying glass to see it slowly seeping out onto the can.
 

mdo817

Well-Known Member
Joined
Jan 17, 2011
Messages
1,905
Skidkid said:
I also recommend removing the hydraulic steering cylinder link or links off of shaft. This allows the cylinder the bottom out removing any possible trapped air. Also, make sure the layout of your steering cooler doesn't trap air. Round tube type coolers should be vertically mounted.

I've heard mounting orbital valves up high can cause trapped air as well. Your res should be the highest mounted part of your steering system.

Return line on the res must be towards the bottom edge as you need your returning fluid to be below res fluid level.
Thanks


Sent from my iPad using Tapatalk
 

mdo817

Well-Known Member
Joined
Jan 17, 2011
Messages
1,905
1TONTJ said:
It leaked a little when the engine wasn't running but it was such a small amount it took forever to see the fluid buildup. I had to get everything squeaky clean and then use a dang magnifying glass to see it slowly seeping out onto the can.
When I bleed and tighten everything I will clean everything also. I have not seen any dripping but I will look, seems like it must be sucking air from somewhere


Sent from my iPad using Tapatalk
 

Primary

HardlineCrawlers Assistant
Here are some related products that HardlineCrawlers members are talking about. Clicking on a product will take you to HardlineCrawlers’s partner, Primary, where you can find links to HardlineCrawlers discussions about these products.

 
 
Top