• Help Support Hardline Crawlers :

Yamaha Rhino issues

Rockwells607

Well-Known Member
Joined
Feb 18, 2010
Messages
1,758
Location
corning ny
I’m at the end of my rope with this thing . I’m still having the reverse issues with it . Originally the issue started where only in reverse the rev limiter ( I think ) kicks on around 2k rpms. It was driveable then. It’s progressed now and seems to come on as soon as you put I in reverse and give it any gas . It starts backfiring and popping and bucking . Things I’ve done : I swapped an after market cdi box in , didn’t fix it , I’ve also grounded the reverse switch wire that I keep reading about which makes the “R” light Go off at all times which supposedly tells the computer there’s no reverse so there’s no rev limiter . It didint work. It only does this in reverse . What Am I missing ????
 

LightBnDr

Well-Known Member
Joined
Apr 26, 2014
Messages
1,620
Re: Yamaha Rhino issues

You got broken motor mounts?

What year is it?

Had anyone watch what the motor does when you load up in reverse?
 

Bebop

Well-Known Member
Joined
Jan 27, 2013
Messages
1,732
Pull the reverse sensor off the gearbox or wherever it is and try again ?
 

BUG-E J

Don't get #labroned
Joined
Dec 1, 2010
Messages
5,177
I'm with enzo. I don't think it has to see a reverse signal. Pop the linkage off and manually put it in reverse and see what happens.
 

smbroady82

Well-Known Member
Joined
Feb 22, 2012
Messages
4,445
Location
Huntsville, AL
mine is an 04 or 05 and it was having reverse issues, we adjusted the shifter and it helped some , it wasn't a rev limiter type issue though, just wouldn't pull

the reverse light does stay on for quite a while after shifting into another gear though, doesn't seem to affect anything so I don't really worry about it
 

sexxy

Well-Known Member
Joined
Apr 22, 2013
Messages
626
Just a random, possibly related possibly not, do the reverse gears in the transmission give trouble? I maybe thinking of a totally different sxs but thought there were reverse issues in some rhino transmissions that ended being gear related.

Once you do find the issue lets us know what fixed it. I have 2 rhinos that the kids and I play on and I try to fix everything myself.
 

Rockwells607

Well-Known Member
Joined
Feb 18, 2010
Messages
1,758
Location
corning ny
I tried unhooking linkage, makes no difference , took the sensor out made no difference , I unhooked the ebrake and that did nothing . I’m stumped . The light on the dash works which makes me think the wires are fine . Idk I’m lost
 

sexxy

Well-Known Member
Joined
Apr 22, 2013
Messages
626
May be a dumb thought. Checked coil wires, in and out? Just shooting in the wind.
 

Primary

HardlineCrawlers Assistant
Here are some related products that HardlineCrawlers members are talking about. Clicking on a product will take you to HardlineCrawlers’s partner, Primary, where you can find links to HardlineCrawlers discussions about these products.

 
 
Top